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+2 Accountancy with Computerised Accounting
Guidelines for Lab Work and Practical Evaluation 

Areas to be covered for the practical work:
Part III Optional Computerised Accounting System is divided in to

six units, and the first unit is purely theoretical, for which no lab work is
necessary.  The  second,  third  and  fourth  units  deal  with  electronics
spreadsheet and its diverse applications in business,  while the fifth unit
establishes the underlying features of accounting software(GNU Khata).
The sixth and last unit deals with practical aspects of managing database
for accounting. Accordingly the practical areas can be broadly grouped in
to three as follows-

Si No Area Unit No.of Programs

1 Spreadsheet -Calc II, III & IV 12

2 GNU Khata V 4

3 DBMS- Base VI 4

Total 20
                   

Practical Log Book:
All the activities related to lab work are recorded in Practical Log

Book (PLB). The Practical Log Book should contain a minimum of 20
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works as specified in the practical syllabus. The format of recording in
Practical Log Book may be as follows :

STRUCTURE & SPLIT UP OF SCORE IN EXAM:
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PART A 
SPREADSHEET (1 to 10) 

(For Exam Attend TWO questions, 
2x6=12 )

LIBRE OFFICE CALC
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1.Given below is  a  table  showing the Name, Designation and Monthly
Salary paid for different employees in Kasaragod traders for March 2021
EMPLOYEE NAME DESIGNATION MONTHLY SALARY

AMANRAJ CLERK 25000

ASHWIN ACCOUNTANT 40000

NANDAKISHOR SALESMAN 32000

DIVIN BOBY SALESMAN 33000

SUHAIL CLERK 25000

VANDITHA MANAGER 50000
Find out the following:

a) The total monthly salary paid in March 2021.
b) The total monthly salary paid to salesman in the firm.
c) The name of the employee with monthly salary of Rs.40,000 by using
LOOKUP Function.

Step 1: Open LibreOffice Calc
Applications  →  Office →  LibreOffice Calc

Step 2: Enter the details as follows
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Step 3 : To get the total salary paid in March 2021 type the formula in 
     C8      =SUM(C2:C7)  and press Enter key.

Step 4: To get total monthly salary paid to the SALESMAN type the 
   formula in C9  
   =SUMIF(B2:B7,”SALESMAN”,C2:C7) and press Enter key

Step 5:To find out the name of the employee with monthly salary of
            Rs.40,000 by using LOOKUP Function .Type the formula in C10
            =LOOKUP(40000,C2:C7,A2:A7) and press Enter key
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2.Yadu Krishnan obtained the  following Scores  out  of  100 in  his  HSS
Examination March 2022.

Convert  the  above  Scores  into  Grades  for  each  subject  based  on  the
following criteria, by using IF function.

               

Step 1 : Open LibreOffice Calc spreadsheet
             Applications → Office → LibreOffice Calc

Step 2 : Enter the Labels – SUBJECT, SCORE AND GRADE in the cells
             A1, B1 and C1 respectively.
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Step 3 : Enter the details given in the question in respective cells.
            

Step 4: Enter the formula in cell C2
=IF(B2>=90,"A+",IF(B2>=80,"A",IF(B2>=70,"B+",IF(B2>=60,"B",IF(B2
>=50,"C+",IF(B2>=40,"C",IF(B2>=30,"D+",IF(B2>=20,"D","E"))))))))

     Then select the cell C2 again and drag from C2 to C7.
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3.Enter the following data exactly as given in the table and answer the
following questions with the help of appropriate COUNT functions.

a) No. of cells which are not empty
b) No. of empty cells in the range
c) No. of cells that have only numbers
d) No. of cells that have the value 'SOAP'
e) No. of cells that have value greater than 3000
f) No. of cells that have value less than 1000

Step 1 : Open LibreOffice Calc spreadsheet
Applications → Office → LibreOffice Calc

Step-2 : Enter the values given in the table exactly as in table in the range 
     A1:D5
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Step 3 : Enter the following Text  in the cells as in the below table
CELL TEXT TO BE ENTERED

E1 No. of cells that is not empty

E2 No. of empty Cells

E3 No. of cells that contains numbers

E4 No. of cells that contains 'SOAP'

E5 No. of cells that have values greater than 3000

E6 No. of cells that have values less than 1000

Step 4 : Enter the following Formulas in the cells as in the below table
CELL FORMULA TO BE ENTERED

F1 =COUNTA(A1:D5)

F2 =COUNTBLANK(A1:D5)

F3 =COUNT(A1:D5)

F4 =COUNTIF(A1:D5,"SOAP")

F5 =COUNTIF(A1:D5,">3000")

F6 =COUNTIF(A1:D5,"<1000")

Prepared by:Sandeep Kumar N V, HSST Commerce, Katukukke HSS,Kasaragod           PAGE10
For more visit : https://hsstimes.blogspot.com             Sandeep Neelian@Kasaragod

OUTPUT:

Join Now: https://join.hsslive.in/group Downloaded from www.Hsslive.in ®

https://hsstimes.blogspot.com/


4.From the following information create a Pivot Table to give country wise
sales of the products

Step 1 : Open LibreOffice Calc spreadsheet
Applications → Office → LibreOffice Calc

Step 2:      Enter table headings (Labels) :
Sl. No. in cell A1, Products in cell B1, Sales Volume (Rs) in cell C1

& Country in cell D1.

Step-3: Enter the details given in the question in respective cells
             

Step-4: Select the entire data including labels like Si No, Products, Sales
            Volume (A1:D7) to create Pivot Table.
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Step-5: Create Pivot Table.
Data----Pivot Table---Create----Current Selection----Ok

Step 6 : In the Pivot Table Layout window, drag fields for the Pivot Table
             from the available fields as follows-

Drag and drop Products field from Available fields to Row fields

Drag and drop Country field from Available fields to Column fields

Drag and drop Sales Volume (Rs) field from Available fields to Data
fields and click on OK button.
    (Data Fields’ always filled with ‘numerical’ values.) For information
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5.Mr. Adhithyan intends to apply for Civil Service examination this year.
But the upper age limit is 32 as on 01/08/2016. Determine whether he is
eligible to apply or not.  Based on the cut  off  age.  His date of birth is
06/09/1982 using appropriate spreadsheet functions.

Step-1: Open LibreOffice Calc
Step-2: Enter the labels in different cells as follows

Step-3: Compute the Date Value of such date in B1 and B2 by the formula
B1= DATEVALUE(“01/08/2016”)
B2=DATEVALUE(“06/09/1982”)

Step-4: Calculate difference between these date values in the cell B3 by 
       the formula B3=B1-B2

Step-5: Calculate the age of the person in the cell B4 by the formula
B4=ROUND(B3/365,0)

Step-6: Determine the Eligibility with the formula in the cell B5
B5=IF(B4<=32,”ELIGIBLE”,”NOT ELIGIBLE”) & press Enter
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6.(a)  The  following  are  the  scores  obtained  by  some  students  in  a
competitive  examination.  Find  out  the  HIGHEST,  LOWEST  and
AVERAGE score using appropriate function in spread sheet.

(b)From  the  data  given  below  Fill  the  Address  in  F2  using
CONCATENATE Function.

(a):
Step-1: Open LibreOffice Calc
Step-2: Enter the details given in the question in respective cells.
Step-3: Enter the labels in different cells as follows

Step-4: Calculate the HIGHEST Score in cell B3 by the formula
            =MAX(B2:H2)
Step-5: Find the LOWEST rank in cell B4 by the formula

=MIN(B2:H2)
Step-5: Find the AVERAGE mark in cell B5 by the formula

=AVERAGE(B2:H2)
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(b):
Step 1 : Open LibreOffice Calc spreadsheet

Applications → Office → LibreOffice Calc

Step-2: Enter the details given in the question in respective cells
             except address

Step-3: Enter the formula in the cell F2 as
=CONCATENATE(A2,",",B2,",",C2,",",D2,",",E2)
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7. a) From the following Table, find out the BASIC PAY of Mr. Ajith
using VLOOKUP Function using EMPCODE 1846

 b).From  the  following  details,  Find  out  the  actual  profit  for
QUARTER II using HLOOKUP Function

 

(a):
Step-1: Open LibreOffice Calc
Step 2: Enter all the details given in the question in respective cells.
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Step-3: To find out the BASIC PAY of Mr.Ajith using VLOOKUP
             Function using EMPCODE 1846, enter the following formula
             in D7
             =VLOOKUP(1846,A2:C5,3,0)

(b):
Step-1: Open LibreOffice Calc
Step 2: Enter all the details given in the question in respective cells.

Step-3: To find out the profit of the QUARTER II in the cell E7 by
            the formula
            =HLOOKUP(C1,B1:E4,4,,0)
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8.  Assume  that  your  School  have  only  Commerce  and  Science
batches. You are required to enter the following list of students after
creating the data validation. Data validation Rules are

a) Age should be between 15 and 20.
b) The Batch must limit to Commerce and Science.

Step 1: Open a blank worksheet in Libre Office Calc
Step 2: Enter the table headings in various cells as given below

Step 3: Enter Admission No from A2:A6 and Name from B2:B6
            as given in the question.

Step 4: Select the range C2:C7, then go to the menu 
            Data > Validity.
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Step 5: In Validity Dialogue box, under the Criteria tab against
           'Allow', select 'List' from the combo box.

Step 6: Then against 'Entries' displayed below enter the batch names,
            one in each line, by pressing Enter key
                  COMMERCE
                  SCIENCE         and press OK 

Step 7: Select the ranges from D2 : D6
           In Validity Dialogue box, under the criteria tab against 'Allow'
           select 'Whole Numbers' from the combo box.

Step 8: Then against 'Data' , select 'Valid range' from the combo box

            Then against 'Minimum', enter 15 and against 'Maximum',
             enter 20        and press OK

Step 9: Then enter the data given in the question in the table.
            When invalid entries are made the error message appears
            restricting invalid entry.
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9.List  of  Debtors  and the amount  due from them are given below.
Apply Conditional formatting to high light receivables with date that
have expired on 31/01/2016.  Also highlight  the debts  more than ₹
35000 with red colour.

Step-1: Open a blank worksheet in LibreOffice Calc
Step-2: Enter the labels as
            

Step  3: Enter the details given in the question in respective cells.

Step 4: Select the range D2:D6, select Conditional Formatting 
            from Format menu  > Click on Condition

Step 6: Then in the conditional formatting dialogue box under
            condition1, select 'Cell Value is' in first combo box. 

In second combo box select 'less than'. In the next box
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            type the text exactly as given below  
                           Datevalue(“31/01/2016”)

Step 7: Then from the combo box given against 'Apply Style' ,
           select 'New Style'. In cell style menu select 
           Background----Select Red colour - Press – OK – OK

Step 8: Select the range C2: C6 to apply conditional formatting for
               the amounts greater than  35,000₹

Step-9:  Then go to the menu Format> Conditional
              Formatting>Condition.

Step 10: Then in the conditional formatting dialogue box under
              condition1, select' Cell Value is' in first combo box. In
              second combo box select 'greater than'.  
              In the next box  type '35000'

Step 11: Then from the combo box given against 'Apply Style' ,
                select 'New Style'. In cell style menu select 
                Background----Select a colour - Press – OK – OK           
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10.Consider the following information
• Loan amount –  300,000₹
• No. of Payments – 48 months
• Annual Rate of interest – 10%

Prepare a one variable table showing the repayment of the above
loan in different number of payment such as 12 months, 24 months, 36
months, 48 months, 60 months and 72 months. Use PMT Function.

(Note : One variable data table is based on an equation ,Here it is PMT 
Syntax    =PMT(Rate,NPER,PV,FV,Type) For Information only,

Step 1: Open a new work sheet in LibreOffice Calc
Step 2: Enter the details given in the question as follows

Step 3: In B6 , Enter the formula
             =PMT(B1/12,B2,B3,B4,B5)
              Returns the value   7608.78₹

Step 4: Type the numbers (NPER) 12,24,36,48,60,72 in the range
             A9:A14
           Create a table as follows (It may be either Column wise 
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            or Row wise- Here it is Column wise)

Step 5: Select the range A9:B14 
          Click  Data -> Multiple operations 
           Set the dialogue box as
           Formulas :  $B$6
           Column input cell : $B$2  & Press OK
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11 to 15
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LIBRE OFFICE CALC
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11. The total commission earned by Mr.Prajwal and Mr.Robith for the
year 2013 – 2017 are given below

  

a) Present the data in a column chart
b) Change the chart type to line chart

Step 1: Open LibreOffice Calc spreadsheet
    Applications → Office → LibreOffice Calc

Step 2: Enter the given details in respective cells as below

Step 3: Select the data range A1:C6 to prepare Column chart.
Then Go to INSERT Menu → CHART
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Step 4: A Chart Wizard window appears.

a)Chart Type : Here select the chart type as COLUMN Chart. Click Next

b)Data Range: Check box against “First Column as Label”. Click Next button 

c)Data Series : We can remove unwanted Data series (If necessary) –Next

d)Chart Elements : Give suitable title, X-axis title,Y-axis title etc for the chart.
Title : Commission Earned 
X-Axis : Year
Y-Axis: Amount
and click FINISH button to insert chart

B) Change Column chart to Line Chart
Step 1 : Double click on Column chart
Step 2 : Select Format menu → Chart type
Step 3 : Select Line chart from Chart type. Select style of Line chart. 
             Click on OK button.
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12.Draw a pie chart for the following data on vehicles registered in the
motor vehicles department during 2021 – 2022 in Kasragod .

Step 1 : Open LibreOffice Calc spreadsheet
Applications → Office → LibreOffice Calc

Step 2 : Enter the given details in respective cells as below-

Step 3 : Select the data range A1:G2 to prepare Pie chart.
               Then Go to INSERT Menu → CHART    
  
Step 4: A Chart Wizard window appears.
a) Chart Type: Here select the chart type as PIE Chart. Click Next button

b) Data Range : (A1:G2 range already selected) Click Next button

c) Data Series :We can remove unwanted Data series (If necessary) –Next

d) Chart Elements : Give suitable title, Sub Title etc. for the chart.
Title : VEHICLES REGISTERED
Subtitle : 2021-2022
and click FINISH button to insert chart

Prepared by:Sandeep Kumar N V, HSST Commerce, Katukukke HSS,Kasaragod           PAGE28
For more visit : https://hsstimes.blogspot.com             Sandeep Neelian@Kasaragod

QUESTION 12

Title:  Pie Chart Preparation

PROCEDURE

Join Now: https://join.hsslive.in/group Downloaded from www.Hsslive.in ®

https://hsstimes.blogspot.com/


Prepared by:Sandeep Kumar N V, HSST Commerce, Katukukke HSS,Kasaragod           PAGE29
For more visit : https://hsstimes.blogspot.com             Sandeep Neelian@Kasaragod

OUTPUT  :

Join Now: https://join.hsslive.in/group Downloaded from www.Hsslive.in ®

https://hsstimes.blogspot.com/


13.Below  are  the  details  of  various  assets  in  HSSTIMES  Ltd.
Calculate depreciation under straight  line method using spreadsheet
software.

Step 1 : Open LibreOffice Calc spreadsheet
Applications → Office → LibreOffice Calc

Step 2 : Enter the labels and values as given below-

Step 3: Calculate Total Cost in the cell H2 by the formula 
             =SUM(B2:E2) and copy the formula to cell H3.

Step 4 : Calculate annual depreciation of the asset Machinery in the
             cell I2 by the formula =SLN(H2,F2,G2) and then copy 
             the  formula to cell I3 to find depreciation  of Furniture.
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14.A machinery was purchased on 1st April 2013 for Rs. 200000. Its
estimated life is 10 years with salvage value of Rs. 20000. Accounting
year  is  1st  April  to  31st  March every year.  Using built-in  function
(Spreadsheet)  calculate  depreciation under the Diminishing Balance
Value method for 5th year.

Step 1: Open LibreOffice Calc spreadsheet
    Applications → Office → LibreOffice Calc

Step 2: Enter the labels and values as given below

Step 3: Calculate Depreciation for 5th year in cell B5
             Syntax=DB(cost,salvage,life,period,month)
                     B5=DB(B1,B2,B3,B4)
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15.The following are the details  of a  plant and machinery under WDV
method using spreadsheet.

Step 1: Open LibreOffice Calc spreadsheet
Applications → Office → LibreOffice Calc

Step 2: Type the label and values as follows
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Title:  Depreciation – DB Method 2

PROCEDURE
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Step 3: To find out Total cost ,in B4 Enter the formula
             =SUM(B1:B3)

Step 4: Compute depreciation in cell B9
            B9=DB(B4,B5,B6,B7,B8)
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15.Prepare payroll of the following employees

Additional Information
1. DA – 36% of Basic Pay
2. HRA – Rs.1750 for employees Basic Pay greater than Rs. 52000,

for others Rs.1500.
3. TA – 400 per Employee
4. PF subscription – 10% for Gross Pay.
5. TDS – 20% for Gross Pay greater than Rs. 60000, otherwise 10%
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Step 1 : Open LibreOffice Calc spreadsheet
Applications → Office → LibreOffice Calc

Step 2: Enter the details as follows

Step 3: Enter formula
In C2 =B2*36%
In D2 =IF(B2>52000,1750,1500)
In E2 ,Enter 400 for all employees (not a formula)
In F2 =B2+C2+D2+E2
In G2 =F2*10%
In I2 =IF(F2>60000,F2*20%,F2*10%)
In J2 =G2+H2+I2
In K2 =F2-J2

Step 4: Drag each formula down to get remaining columns filled.
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PART C-
GNU Khata (17 to 20)

(For Exam Attend ONE 
question, 1x6=6 )

GNU KHATA
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16.The various transactions relating to HSSTIMES Traders for the month
of  January  2016 is  given  below.  Ascertain  cash  balance  for  the  month
using Gnu Khata.

Jan 1. Started business with cash Rs. 50000
Jan 1 : Purchased office furniture Rs. 4500
Jan 1 : Cash purchases Rs.25000
Jan 1 : Credit sales to Anand Rs. 43000
Jan 2 : Salary to staff Rs. 12000
Jan 2 : Received from Anand Rs. 17500

Step1: Open GNU Khata
Application → Office  →GNU Khata

Step 2: Create Organisation
Select Create organization from the Menu

Enter  Organisation  name→  HSSTIMES  Traders  →Case  As-is  
→Organisation → Profit making
Financial year 01/01/2016 to 31/12/2016 → Select Accounts Only →
Proceed

Step 3: Create Admin
Enter User name, Password, Confirm password, Enter security 

     question, answer security question, Create and login.

Step 4: Create Ledger Accounts
Master →Create Account →Select Group→Select Sub Group

→ Enter Account Name →Save as follows
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Title: Voucher Entry – Cash Account

PROCEDURE
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Step 5: Enter the transactions through appropriate vouchers as listed below

Step 6: Uncheck Monthly Ledger , Set From Date as 01.01.2016 and To
             Date as 31.01.2016 and Click on View.

(ANSWER: Cash A/C debit balance Rs.26,000)
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17.Enter the following transactions using appropriate accounting vouchers
and show the Purchase and Sales Ledgers of PILICODE Traders

01/01/2016 Started business with cash Rs. 150000
01/01/2016 Deposited in to SBI Rs 40000
01/01/2016 Purchased goods from Aruna Traders Rs. 25000
02/01/2016 Purchased goods Rs. 5000
02/01/2016 Sold goods Rs. 4000
02/01/2016 Purchased goods for Rs. 10000 and paid by cheque
02/01/2016 Sold goods on credit to Aneesh for Rs. 15000

Step1: Open GNU Khata
Application → Office  →GNU Khata

Step 2: Create Organisation
Select Create organization from the Menu

Enter  Organisation  name→  PILICODE  Traders  →Case  As-is  
→Organisation → Profit making

Financial year 01/01/2016 to 31/12/2016 → Select Accounts Only →
Proceed

Step 3: Create Admin
Enter User name, Password, Confirm password, Enter security 

     question, Answer security question, Create and login.

Step 4: Create Ledger Accounts
Master →Create Account →Select Group→Select Sub Group

→ Enter Account Name →Save as follows
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Title: Voucher Entry – Purchase and Sales Ledger
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Step 5: Enter the transactions through appropriate vouchers as listed below
      

Step 6: Uncheck Monthly Ledger , Set From Date as 01.01.2016 and To
             Date as 31.01.2016 and Click on View.
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 (ANSWER:Purchase Ledger Closing balance Rs. 40,000)

(ANSWER: Sales Ledger Closing Balance Rs. 47,000)
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18.Enter the following transactions of Nihal by using suitable accounting
vouchers and display the profit and loss account and balance sheet.

01/06/2016 Commenced business with cash Rs. 17000
01/06/2016 Purchased machinery Rs. 10000
01/06/2016 Paid Rent of building Rs. 7500
01/06/2016 Cash deposited with Canara bank Rs. 20000
01/06/2016 Purchased goods for Rs. 8400
02/06/2016 Sold goods for cash Rs. 3260
02/06/2016 Sold goods on credit to Mr. Rajesh Rs. 2800

Step1: Open GNU Khata
Application → Office  →GNU Khata

Step 2: Create Organisation
Select Create organization from the Menu

Enter  Organisation  name→  Nihal  Traders  →Case  As-is  
→Organisation → Profit making

Financial year 01/01/2016 to 31/12/2016 → Select Accounts Only →
Proceed

Step 3: Create Admin
Enter User name, Password, Confirm password, Enter security 

     question, Answer security question, Create and login.

Step 4: Create Ledger Accounts
Master →Create Account →Select Group→Select Sub Group

→ Enter Account Name →Save as follows
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Title: Profit and Loss Account and Balance sheet
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Step 5: Enter the transactions through appropriate vouchers as listed below

      

Step 6 : Display Profit and Loss A/c 
 Report → Profit & Loss

Set, View Profit & Loss for the period from 01.01.2016 to

       31.12.2016 and Click on  → View button.

Step 7 : Display Balance Sheet
 Report → Balance Sheet

Prepared by:Sandeep Kumar N V, HSST Commerce, Katukukke HSS,Kasaragod           PAGE45
For more visit : https://hsstimes.blogspot.com             Sandeep Neelian@Kasaragod

Join Now: https://join.hsslive.in/group Downloaded from www.Hsslive.in ®

https://hsstimes.blogspot.com/


Set,  View Balance  Sheet  for  the  period  from 01.01.2016  to
31.12.2016 and Balance Sheet Type as Conventional Balance
               Sheet. Then Click on View button.

(ANSWER: Net Loss - 9840)

(ANSWER: Balance Sheet Total-7160)
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19.Create the following ledgers in GNU Khata and display the balance
sheet as on 01/04/2017 in the books of Neelian Traders, Kasaragod

Step1: Open GNU Khata
Application → Office  →GNU Khata

Step 2: Create Organisation
Select Create organization from the Menu

Enter  Organisation  name→  Neelian  Traders  →Case  As-is  
→Organisation → Profit making

    Financial year 01/04/2017 to 31/03/2018 → Select Accounts Only → 
Proceed

Step 3: Create Admin
Enter User name, Password, Confirm password, Enter security 

     question, Answer security question, Create and login.

Step 4: Create Ledger Accounts (with opening balance)
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Title: Ledger creation with opening balance and Balance sheet

PROCEDURE
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Master →Create Account →Select Group→Select Sub Group
→ Enter Account Name →Save as follows

Step-5: Display Balance Sheet
Report→Balance Sheet→set the period→Select 

          Conventional Balance Sheet type→click on view.

(ANSWER: Balance sheet total- 22,05,000)

Prepared by:Sandeep Kumar N V, HSST Commerce, Katukukke HSS,Kasaragod           PAGE48
For more visit : https://hsstimes.blogspot.com             Sandeep Neelian@Kasaragod

OUTPUT

Join Now: https://join.hsslive.in/group Downloaded from www.Hsslive.in ®

https://hsstimes.blogspot.com/


Prepared by:Sandeep Kumar N V, HSST Commerce, Katukukke HSS,Kasaragod           PAGE49
For more visit : https://hsstimes.blogspot.com             Sandeep Neelian@Kasaragod

PART D : DBMS -LibreOffice 
Base 

(21 to 25)
(For Exam Attend ONE 

question, 1x6=6 )

LIBRE OFFICE BASE
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20.Enter the following in a database table with the file name Emp_details.
    

a)Display the name of employees drawing BASIC PAY greater
than or

equal to 60000.
b) Display the name of employees begin with 'A'.

Step 1 : Open LibreOffice Base
Applications → Office → LibreOffice Base

Step 2 : Create New Database.
• Database Wizard → Create a new database → Next → Finish
• Save the new database with a file name & select location.

Step 3: Create Table
From the Database Panel, select Create Table in Design view.
Create the following Field Name with appropriate field Type

                

• Select and set EMP_ID field as Primary Key
• Save the Table Design with a name 'Emp_details_Table'
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QUESTION 21

PROCEDURE

Title: Table Creation and Query Designing in Base
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Step 4: Close the screen by clicking X button and 
  Enter data in the newly created Table as given in the question

by  double clicking  the created table.

             

       
Step 5: Design query for Basic Pay >=60000

   From the Database Panel, select the object Queries &
             Select Create Query in Design View.

• A small window appears
• Select the object Table and 'Emp_details_Table'
• Then  click  on  Add  button  at  the  bottom  and  Close  the

window.
• Double click in the required fields (EMP_ID, EMP_ NAME,

EMP_SEX, EMP_BASICPAY)

Step 6: Against the criterion under EMP_BASICPAY
 Enter the criteria >=60000.

  Then press F5 or run query button to display the results & save
            the query by giving a name “ >=60000_QUERY”
 

Step 7: (Design Query to get the list of name of employees begin with “A”)
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From the Database Panel, select the object Queries &
            Select Create Query in Design View.

Select 'Emp_details_Table' Add→Close→double click on the
               required fields.

Step 8: Against the criterion in the EMP_NAME column-
• Enter the criteria LIKE ‘A*’
• Then press F5 or RUN Query button to display the result.
• Save the Query with name “Starting_With_A”
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21.
a)Prepare a payroll of employees with the gross pay on the basis of the
following database table.
    

   DA : 20% of Basic Pay
b).Display the salary details of the employees whose names ending with 'A'.

Step 1 : Open LibreOffice Base
Applications → Office → LibreOffice Base

Step 2 : Create New Database.
• Database Wizard → Create a new database → Next → Finish
• Save the new database with file name 'PAYROLL' and by selecting

suitable location. 
Step 3: Create Table

 From the Database Panel, select Create Table in Design view.
Create  the  following Field  Name with  appropriate  field  Type  as

follows
            

• Select and set EMP_ID field as Primary Key
• Save the Table Design with a name 'Payroll_Table’
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Title: PAYROLL PREPARATION IN LIBREOFFICE BASE

PROCEDURE
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Step 4: (Enter data in the newly created Table)
• Double click on the newly created table 'Payroll_Table’
• Enter  the  details  of  all  employees  in  the  table  as  given  in  the

question. 
• Then close the window (X).

Step 5: (Find out DA and GROSS PAY)
• From the Database Panel, select the object Query.
• Select Create Query in Design View.
• A small window appears namely, Add Table or Query.
• Select the object Table and select ‘Payroll_Table’ & add.
• Double click on the required fields here select

    EMP_ID, EMP_NAME,EMP_BASICPAY & HRA

Step 6: In the next column, against the Field, enter the following formula 
  to calculate 20% of Basic Pay as DA.

“EMP_BASICPAY”*20/100

Step 7: Against the ‘Alias’ in this column enter the term DA, to define the 
name of the field.

Step 8: In the next column, against the Field, enter the following formula 
to calculate GROSS SALARY of the employees.

           “EMP_BASICPAY”+“HRA”+ “EMP_BASICPAY”*20/100

Step 9: Against the ‘Alias’ in this column enter the term GROSS SALARY,
 to define the name of the field. It will be as follows

         
Step 10: Then press F5 or “Run Query” button to display the result
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• Save the query with name ‘Payroll_Query’

Step 11: (Design Query to get the list of name of employees ending with
“A”)

• From the Database Panel, Click on the  object Query
• Right click on already created Query and select ‘Copy’
• Then again right click blank space under the heading Query and

Paste the same.
• Give a suitable name , here ‘Starting_with_A_Query’

Step 12: Editing the Query
• Right Click on ‘Starting_with_A_Query’
• Select Edit
• Against the criterion in the EMP NAME column, enter the criteria

      LIKE ‘*A’
• Then press F5 or RUN Query button to display the result & save

Prepared by:Sandeep Kumar N V, HSST Commerce, Katukukke HSS,Kasaragod           PAGE55
For more visit : https://hsstimes.blogspot.com             Sandeep Neelian@Kasaragod

OUTPUT 1: PAY ROLL

OUTPUT 2: NAME OF EMPLOYEES ENDING WITH “A”

Join Now: https://join.hsslive.in/group Downloaded from www.Hsslive.in ®

https://hsstimes.blogspot.com/


22.Create a database table named TABLE_EMPLOYEE and enter the following
details using a form.

Also create a query to display EMP_NAME and BP.

Step 1 : Open LibreOffice Base
Applications → Office → LibreOffice Base

Step 2 : Create New Database.
• Database Wizard → Create a new database → Next → Finish
• Save the new database with file  name 'CREATION_OF_FORM'

and by selecting suitable location. 

Step 3: Create Table
 From the Database Panel, select Create Table in Design view.
Create  the  following Field  Name with  appropriate  field  Type  as

follows
             

• Select and set EMP_ID field as Primary Key
• Save the Table  with a name 'TABLE_EMPLOYEE’
• Then Close the screen by click (X)

Step 4: (Enter data in the newly created Table through FORM)
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Title: Data entry through FORM

PROCEDURE
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• From the Database Panel, select the object Forms
• Select Use Wizard to create Form.
• Through the Form Wizard, Select 'TABLE_EMPLOYEE’
• Add Available Fields to Fields in the Form.
• Select appropriate arrangement for the Main Form
• Select style of the Form
• Set name of the Form as ‘FORM_EMPLOYEE’ and Finish.

Step 5: Data entry to the Table through Form

After entering all data, close the form (x)

Step 6 : To show EMP NAME and BP
• From the Database Panel, select the object Query.
• Select Create Query in Design View.
• A small window appears namely, Add Table or Query.
• Select the object Table and select TABLE_EMPLOYEE’ & add.
• Double click on the required fields ,here select  EMP_NAME &

BP

Step 7: Then press F5 or “Run Query” button to display the result
• Save the query with name ‘OUTPUT’
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23.Create database tables named EMPLOYEE and PAY_DETAILS with
the following field names.

Create relationship between these two tables.

Step 1 : Open LibreOffice Base
Applications → Office → LibreOffice Base

Step 2 : Create New Database.
• Database Wizard → Create a new database → Next → Finish
• Save the new database with file name 'EMPLOYEE_DATA' and

by selecting suitable location. 
•

Step 3: Create TWO Tables- EMPLOYEE & PAY_DETAILS
 From the Database Panel, select Create Table in Design view.

• Create the EMPLOYEE_TABLE as follows

• Set EMP ID as Primary Key. 
• Save Table-1 by click on the save button and give

the name ‘EMPLOYEE_TABLE’
• Then Close the screen by click (X)
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Title: Relationship between tables

PROCEDURE
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Step 4: Create PAY_DETAILS_TABLE as follows
 

• Set EMP ID as Primary Key. 
• Save Table-1 by click on the save button and give

 the name ‘PAY_DETAILS_TABLE’
   Then Close the screen by click (X)

Step 5: Create Relationship between Tables
 Click Tools Menu → Relationships

• ADD TABLES dialogue window appears.
• Select the table EMPLOYEE_TABLE and click on Add button.
• Select the table ‘PAY_DETAILS_TABLE’ & click on Add button.

Step 6:  Connecting tables
• In the Relation Design window Click on Emp_ID field of one

table and drag and drop on to the Emp_ID field of other table.
• A connecting line between these two fields is formed.
• Click  on  save  button  to  save  the  relationship  and  close  the

window.
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24.Create STUDENT table in database with the following fields.

  (Hint: Classes are Science, Commerce and Humanities)
a) Enter six records with imaginary details
b)Prepare of report of students from Commerce Class.

Step 1 : Open LibreOffice Base
Applications → Office → LibreOffice Base

Step 2 : Create New Database.
• Database Wizard → Create a new database → Next → Finish
• Save the new database with file name 'STUDENTS_DATA' and by

selecting suitable location. 

Step 3: Create Table
 From the Database Panel, select Create Table in Design view.
Create  the  following Field  Name with  appropriate  field  Type  as

follows

• Set field length as given in the question by entering value
in Length Column under each field name

• Select and set STUD_NO field as Primary Key
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Title: PREPARATION OF REPORT

PROCEDURE
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• Save the Table  with  name 'STUDENT_TABLE'
Step 4:  Enter six records with imaginary details in 'STUDENT_TABLE'

• Then Close the screen by click (X)

Step 5:  Create list of COMMERCE students using Query
• Queries →Create Query in design view →Select the table →Add

• Double click all the required fields.

• In the Criterion field of the CLASS, enter the text
'COMMERCE' to display only Commerce Students.

• Press F5 key or Run Query button to display the result
• Save the Query with a file name ‘QUERY_COMMERCE’

Step 6 : Create Report
• From the Database Panel, select the object Report
• Use Wizard to Create Report.
• Under field selection, Select ‘QUERY_COMMERCE’
• Add All button (>>) to add all fields in report.
• Click Next for all items ,Make changes if necessary
• Save report by giving name ‘REPORT_COMMERCE’
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• Click finish button.

  

OTHER USEFUL LINKS 

TO GET PRACTICAL FILE SEPARATELY CLICK HERE

TO DOWNLOAD GNU KHATA CLICK HERE

FOR PLUS ONE ACCOUNTANCY MATERIALS CLICK HERE

FOR PLUS ONE BUSINESS STUDIES CLICK HERE

FOR PLUS TWO ACCOUNTANCY CLICK HERE

FOR PLUS TWO BUSINESS STUDIES CLICK HERE

CLICK HERE TO WATCH VIDEO CLASSES
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